News & Announcements

Notice of an upcoming update to Mobiliti, which drives your TouchBanking App:

For all Mobiliti™users beginning June 25, 2017, the minimum standard for establishing a connection with the Mobiliti platform will be TLS v1.2.

TLS v1.0 and v1.1 are being discontinued due to security implications.  TLS is the layer that ensures that connection from the app to the platform is secure, encrypted and safe from malicious attacks.
• Users who are on older OS versions that do not support TLS v1.2, will need to upgrade their mobile OS version to be able to connect to Mobiliti through a TLS v1.2 connection.
• Users who do not have a compatible OS version will get a connection error when attempting to access the Mobiliti platform.
• If issues are encountered, Mobiliti users should be advised to upgrade their OS version to compatible versions as noted below:
o    Users with devices on Android KitKat (4.4 and above) and above will be able to connect   to Mobiliti.
 To find out what version is running on your Android device, go to Settings, About Phone, Software Info.
o    Users with devices on iOS 8 and above will be able to connect to Mobiliti.
 To find out what version is running on your Apple/IPhone device, go to Settings, General, Software Update.